[SOLVED] Code is not showing up

Sep 8, 2012 at 12:23 AM

The solution activated okay and I added ga code to an E3 and a P1 public site, but code doesn't appear when I view source.

Any thoughts?

Sep 8, 2012 at 10:54 AM

The Google Analytics code is stored in a file, and the sites are only referencing the wsp365/googleanalytics.js. This makes the update easier and allows the activation without modifying the master pages. Can you check if this file is there?

Sep 8, 2012 at 2:14 PM
Edited Sep 8, 2012 at 2:15 PM


I thought that and combed through both P and E site’s source code and couldn’t find any reference to a ga.js file.

Sep 8, 2012 at 4:34 PM
Edited Sep 8, 2012 at 4:34 PM

Hmm, confusing. I verified the current solution on E and P installations and it was working. Can you deactivate the sandbox solution and reactivate it again?

Could it be possible, that you have a modified masterpage, as the solution uses the out-of-the-box controls to load the script files.

Are you using the solution on a public URL, can you share the link?

Sep 10, 2012 at 9:12 PM

I gave it a day to see if it would update. I see it now on a non default public site page:


But not on same account default public site:


And not on another account:


The default public site master is unmodified. The non default public site master may have minor mods, but it's working there. 

Sep 16, 2012 at 7:01 PM

Thanks, there was a small bug and it should be fixed in the latest version.

Download the latest release and do the following steps:

1. Deactivate and delete the old solution
2. Upload and activate the new solution
3. Follow the instructions in the main article to republish the Google Analytics code (Goto Site Settings / Google Analytics / Paste the code and click Ok)


Oct 2, 2013 at 7:59 PM
I am having the same difficulty, a year later. I just downloaded the wsp this morning, followed the instructions, and I'm not seeing any GA code being rendered. I placed this on a new, SharePoint Online 2013 collection, below the root level (at https://kc1.sharepoint.com/sites/Train). We don't have a public site, so I didn't try it there. Master Page on /train/ has not been modified. I deactivated and reactivated the wsp, but still not FA code. Thoughts? thx.